友情提示:欢迎光临,本博客提供的代码,请粘贴到EditPlus 3中使用!!请使用火狐,Chrome浏览器进行浏览网站!出售wenca.cn域名,有要的请M我qq:316358892

centos7编译安装ffmpeg

post by rocdk890 / 2017-7-12 9:40 Wednesday linux技术

公司最近要使用音频转码,找到我说要用ffmpeg,让我安装一个,好吧,为了方便以后查阅,故写下这篇文章.
系统:centos 7.x(64位)
软件:ffmpeg 3.3.2
1.下载ffmpeg 3.3.2
wget http://www.ffmpeg.org/releases/ffmpeg-3.3.2.tar.gz

2.下载第三方源
yum -y install epel-release
wget https://www.mirrorservice.org/sites/dl.atrpms.net/el7-x86_64/atrpms/stable/atrpms-repo-7-7.el7.x86_64.rp...

阅读全文>>

标签: centos 安装 编译 install ffmpeg centos7

评论(0) 引用(0) 浏览(87)

centos编译安装nodejs

post by rocdk890 / 2016-5-18 9:56 Wednesday linux技术

  今天我们来单独说说怎么编译安装nodejs,如果会的就看最后,不会的就跟着一步一步的安装走吧.
  系统:centos 6.x(64位)
  软件版本:nodejs 5.3.0
1.先升级gcc版本
升级gcc请看这篇文章linux快速升级gcc版本,这里就不重复说了.

2.下载node
wget http://nodejs.org/dist/v5.3.0/node-v5.3.0.tar.gz
wget http://download.slogra.com/nodejs/node-v5.3.0.tar.gz

3.编译安装node
tar zxf node-v5.3.0.tar...

阅读全文>>

标签: centos 安装 linux 编译 install node nodejs

评论(0) 引用(0) 浏览(1753)

php编译中遇到各种error解决办法

post by rocdk890 / 2016-2-16 16:02 Tuesday linux技术

1) Configure: error: xml2-config not found. Please check your libxml2 installation.
Solutions :
Quote:

# yum install libxml2 libxml2-devel

2) Checking for pkg-config… /usr/bin/pkg-config configure: error: Cannot find OpenSSL’s <evp.h>
Solutions :
Quote:

# yum install openssl openssl-devel

3) Configure...

阅读全文>>

标签: php 错误 编译 error

评论(0) 引用(0) 浏览(892)

解决linux编译ruby1.8.7错误

post by rocdk890 / 2015-11-25 17:01 Wednesday linux技术

  今天同事要求在测试机上安装ruby和rails的时候,居然安装ruby-1.8.7出现编译错误.如下:
ossl_pkey_ec.c:815: error: ‘EC_GROUP_new_curve_GF2m’ undeclared (first use in this function)
ossl_pkey_ec.c:815: error: (Each undeclared identifier is reported only once
ossl_pkey_ec.c:815: error: for each function it appears in.)
make[1]: *** [ossl_pkey_ec.o] Error 1
make[1]: Leaving directory `/home/vagrant/ruby-1.8.7-p357/ext/openssl'
make: *** [all] Error 1

解决方法如下...

阅读全文>>

标签: linux 编译 ruby ruby1.8.7 ruby-1.8.7

评论(0) 引用(0) 浏览(987)

nginx编译报错error: can not detect int size

post by rocdk890 / 2015-8-3 18:00 Monday linux技术

在64位的机器上进行对nginx进行编译配置,居然报错error: can not detect int size,原来是加上了–with-cpu-opt选项.

正如某博客所说去掉cpu优化选项即可通过配置,但是对于有优化强迫症的IT工作者来说这是绝对不容许的.

经过一番研究,设置好CFLAGS参数即可在cpu优化选项开启的情况下通过配置测试...

阅读全文>>

标签: nginx 优化 编译 参数

评论(0) 引用(0) 浏览(2241)

centos为php编译imap扩展

post by rocdk890 / 2015-6-7 23:27 Sunday linux技术

  今天给公司安装了zurmo,他需求的php模块比较多,其中安装imap是我觉得有必要记录下来的,下面分享给大家安装过程.
  系统:centos 6.x
  php版本: php-5.3.10
  apache版本: httpd 2.2.22
  mysql版本: mysql 5.1.61
1.进入php软件扩展目录
cd /root/install/php-5.3.10/ext/imap

2.安装依赖包...

阅读全文>>

标签: centos 安装 php 编译 zurmo imap

评论(0) 引用(0) 浏览(527)

解决centos下编译apache-2.4.x报错汇总

post by rocdk890 / 2014-4-15 17:23 Tuesday linux技术

  今天公司居然要求安装apache-2.4.9的版本,在安装过程中我遇到了2个错误,现在记录下来分享给大家.
  系统:centos 5.x
  需要的软件包:httpd-2.4.9.tar.gz
             &nb...

阅读全文>>

标签: apache 解决 错误 报错 编译 httpd apache-2.4.9 httpd-2.4.9

评论(0) 引用(0) 浏览(5630)

configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works.

post by rocdk890 / 2014-4-4 16:21 Friday linux技术

  今天给同事安装php 5.5.11,居然报错下面的错误:
configure: error: Unable to detect ICU prefix or no failed. Please verify ICU install prefix and make sure icu-config works.
还以为是没有安装perl-ExtUtils-CBuilder perl-Ext...

阅读全文>>

标签: 安装 出错 php 编译 php5.5

评论(0) 引用(0) 浏览(6274)

php编译安装calendar扩展模块

post by rocdk890 / 2014-2-28 10:32 Friday linux技术

  今天同事说服务器上的php缺calendar模块,上去一查还真没有,好吧,只能重新编译下把calendar这个模块给添加进去,这个模块的功能是日历扩展功能,由于开发催得急,就没有多找资料了,下面来说下编译安装吧.
  系统:centos 5.x
  需要的软件包:php5.2.x
1.进入calendar目录
这个要看你把php的编译包丢那了,我是放在/root/inst...

阅读全文>>

标签: 安装 php 模块 编译 calendar

评论(0) 引用(0) 浏览(4827)

解决BalancerMember Can't find 'byrequests' lb method

post by rocdk890 / 2013-9-12 11:10 Thursday linux技术

  今天在公司的另外一台服务器上配置apache整合tomcat,由于apache是编译安装的,很多模块都没有打开,在整合的时候,报下面的错误
点击查看原图
下面我们来解决这个错误,解决方法如下:
1.先确认httpd.conf里有没有proxy的模块,如果没有那就要自己编译添加
进入apache源代码目录下modules目录中的proxy目录里
cd /root/install/httpd-...

阅读全文>>

标签: apache tomcat 编译 proxy apxs

评论(0) 引用(0) 浏览(2239)

ImportError: No module named MySQLdb解决办法

post by rocdk890 / 2013-8-29 9:23 Thursday linux技术

  今天突发奇想在服务器上使用web页面查看系统状态,但又不想去搭建太复杂的监控系统,就在网上找了个相对容易的监控方式,但做到python那步的时候居然报ImportError: No module named MySQLdb,但博主说他是ubuntu的系统可以直接使用apt-get install python-mysqldb,而我是centos系统,只能自己去下源码包来安装.
&nb...

阅读全文>>

标签: mysql web 编译 python mysql-python

评论(2) 引用(0) 浏览(13847)

解决configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.

post by rocdk890 / 2013-8-15 13:53 Thursday linux技术

  今天给php编译安装Fileinfo的时候,报configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.看了下说是要re2c这个东西.
解决办法:
wget http://sourceforge.net/projects/re2c/files/re2c/0.13...

阅读全文>>

标签: 安装 php 错误 编译 install re2c Fileinfo

评论(0) 引用(0) 浏览(7542)

解决编译php报错:error:libjpeg.(a|so) not found.

post by rocdk890 / 2013-7-5 16:27 Friday linux技术

  今天给新服务器编译安装lnmp环境的时候,编译php出现error:libjpeg.(a|so) not found.马上使用命令yum -y install libjpeg安装下再进行编译,居然还是报这个错误,网上搜了下说的要安装libjpeg-devel,好吧,我又把libjpeg-devel也安装再进行编译,居然还是错误,当时就想把电脑给摔了,继续网上搜,还好在一位大神那找到了...

阅读全文>>

标签: centos php linux 错误 编译 libjpeg libpng

评论(0) 引用(0) 浏览(3801)

Curses library not found. Please install appropriate package

post by rocdk890 / 2013-5-20 18:19 Monday linux技术

 今天安装mysql-5.5.3-m3的时候,报下面的错误:
-- Could NOT find OpenSSL (missing: OPENSSL_LIBRARIES OPENSSL_INCLUDE_DIR) 
-- Could NOT find Curses (missing: CURSES_LIBRARY CURSES_INCLUDE_PATH) 
CMake Err...

阅读全文>>

标签: centos mysql 安装 出错 linux 编译 64位

评论(0) 引用(0) 浏览(6109)

php安装eaccelerator报错解决办法

post by rocdk890 / 2013-5-2 9:22 Thursday linux技术

  我的php是yum安装的,为了对其执行加速要安装eaccelerator,但编译的时候报如下的错误:

为了解决这个问题,才有下面这篇文章.
  系统:centos 5.5
  环境:lamp 环境
  需要的软件包:eaccelerator-0.9.6.1.tar.bz2
1.安装配置eaccelerator
wget http://acelnmp.googleco...

阅读全文>>

标签: centos 安装 php 编译 eaccelerator

评论(0) 引用(0) 浏览(2123)