友情提示:欢迎光临,本博客提供的代码,请粘贴到EditPlus 3中使用!!请使用火狐,Chrome浏览器进行浏览网站!出售wenca.cn域名,有要的请M我qq:316358892

vi编辑器常用命令及快捷键

post by rocdk890 / 2012-11-29 15:26 Thursday linux技术

光标控制命令 

命令                        光标移动
h或^h                    向左移一个字符
j或^j或^n                向下移一行
k或^p                    向上移一行
l或空格                     向右移一个字符
G                        移到文件的最后一行
n...

阅读全文>>

标签: linux vi 快捷键 常用命令

评论(0) 引用(0) 浏览(1705)

使用php-fpm来发现执行慢的php文件

post by rocdk890 / 2012-11-29 15:21 Thursday linux技术

  相信大家都想让自己的网站秒开,但很多时候根本就不知道怎么去优化的时候,对数据库和web都优化了,但网站打开还是那么的慢,就只能对程序入手了,我们可以通过php-fpm来查询
  系统环境:lnmp
1.php5.2的设置
vi /etc/php-fpm.conf
//默认秒为单位
<value name="request_slowlog_timeout">10s<...

阅读全文>>

标签: 配置 php-fpm php 查询

评论(0) 引用(0) 浏览(3065)

根目录执行chmod -R 777 / 的补救方法

post by rocdk890 / 2012-11-29 10:06 Thursday linux技术

我相信大家都会遇到这样的问题的,执行后千万不要退出当前窗口!!!
    在自己的虚拟机上设置某个站的权限的时候,原来应该是chmod -R 777 ./*  结果少按了个点,执行了chmod -R 777 /*  因为执行时间超出自己的预想范围赶紧按下CTRL+C,可惜晚了,看下了/etc目录下的东西,全部都是777状态,立马开另一个终端尝试登陆,已经登录不...

阅读全文>>

标签: linux 解决 权限 chmod 根目录 补救

评论(1) 引用(0) 浏览(2945)

ros多adsl负载掉线后自动修改pcc nth参数

post by rocdk890 / 2012-11-28 14:06 Wednesday 网络技术

  我们公司的ros今天出现一条adsl掉线,手动去修改pcc参数太麻烦了,找了几个pcc脚本,还是发现下面的这个简单好用易懂点.

1.自动修改PCC参数脚本:

{
:local status
:local i "6"
:local x "0"
:local y "0"
:local z "0"
:set x [:len [/interface pppoe-client f...

阅读全文>>

标签: 参数 脚本 ros 负载 pcc nth

评论(0) 引用(0) 浏览(6677)

centos在被监控端安装nrpe

post by rocdk890 / 2012-11-27 10:16 Tuesday linux技术

  上一篇介绍了centos安装nagios服务端,现在我们要在被监控的服务器上安装nagios-plugins和nrpe,来保证nagios服务端可以监控所有的服务器.
  系统:centos 5.8
  需要的软件包:nagios-plugins-1.4.15.tar.gz nrpe-2.12.tar.gz
1.安装nrpe依赖包
yum -y install g...

阅读全文>>

标签: 监控 服务端 nagios nrpe 被监控端

评论(0) 引用(0) 浏览(3712)

解决gmail访问缓慢(六)

post by rocdk890 / 2012-11-26 22:14 Monday windows技术

  没想到最近国内对google封杀越来越BT,让我们这些想用google搜点资料都麻烦得很.但我本人又是那种很懒的,不想开vpn和代理的,只想通过修改hosts就可以使用google的功能,这可能是最后一次给大家发hosts文件了.
只要在c:\WINDOWS\system32\drivers\etc的hosts文件里加上这几句:
######## Localhost ####...

阅读全文>>

标签: gmail 访问缓慢 无法 访问 google hosts 北京

评论(0) 引用(0) 浏览(4097)

centos安装nagios服务端

post by rocdk890 / 2012-11-26 16:50 Monday linux技术

  系统:centos 5.8
  需要的软件包:nagios-cn-3.2.3.tar.bz2 nagios-plugins-1.4.15.tar.gz nrpe-2.12.tar.gz
1.安装nagios和nrpe依赖包
yum -y install httpd php gcc glibc glibc-common gd gd-devel openssl openssl-...

阅读全文>>

标签: apache centos yum 服务端 nagios nrpe

评论(0) 引用(0) 浏览(1928)

解决svn uuid变更问题

post by rocdk890 / 2012-11-24 15:02 Saturday windows技术

  今天操作SVN Client 发现TortoiseSVN报如下错误:
Command Update
Repository uuid '62b86956-73d9-2945-ba87-0546d71898f9' doesn't match expected
uuid '6aed1349-fe9f-9245-a4a0-02dba53eb2d0'
Finished!

可以看到,原...

阅读全文>>

标签: svn 解决 修改 TortoiseSVN uuid 变更

评论(0) 引用(0) 浏览(7959)

解决gmail访问缓慢问题(五)

post by rocdk890 / 2012-11-20 14:52 Tuesday windows技术

  在十八大开过之后,上一次的hosts又无法使用了,最近这一周都在找google的新hosts文件,终于找到个稳定的,经过亲自验证,感觉速度还不错.
只要在c:\WINDOWS\system32\drivers\etc的hosts文件里加上这几句:
203.208.46.200 0.docs.google.com
203.208.46.200 0-open-opensocial...

阅读全文>>

标签: gmail 访问缓慢 无法 访问 google 缓慢 hosts 北京

评论(2) 引用(0) 浏览(4100)

centos下搭建git服务端

post by rocdk890 / 2012-11-17 18:57 Saturday linux技术

  公司开始从svn转向git了,要求在公司内部搭建个git服务端,下面就是git服务端搭建过程.
  系统:centos 5.5
  git服务端:192.168.1.253 (linux)
  git客户端:192.168.1.155 (linux)
1.安装git
如果没有安装git的话,可以去看我这篇文章centos下两种方法安装git.

2.安装g...

阅读全文>>

标签: centos 配置 安装 ssh key 搭建 git python 服务端

评论(0) 引用(0) 浏览(3777)

centos下yum安装RabbitMQ

post by rocdk890 / 2012-11-16 22:14 Friday linux技术

  今天在公司给了一台256M内存的vps让我安装rabbitmq和php-rabbitmq,当我使用编译安装rabbitmq的时候,vps居然卡在make那一直无法编译下去,让人很烦躁,公司又催着要,没办法之下,只好yum安装了.
   系统:centos 5.5
   需要的软件:epel-release-5-4.noarch.rpm
1.安装前准备
...

阅读全文>>

标签: centos yum 安装 linux rabbitmq

评论(0) 引用(0) 浏览(4796)

ROS多线负载和分流

post by rocdk890 / 2012-11-14 15:23 Wednesday 网络技术

这里以双线Adsl作为基本环境对RouteROS进 行相关的设置,包括adsl配置、共享上网设置、双线负载、双线分流、arp mac绑定等,所有设置均在winbox汉化版下进行,引号内为需要输入的内容。这个方法无论这两条线路是使用固定网关还是动态网关,无论是相同网关或是 不同网关都能起到作用,是一个比较通用的做法,据说也是官方推荐的做法,希望对需要的人有所帮助。
网卡的基本设定为:lan表示内网...

阅读全文>>

标签: 设置 负载均衡 ros 负载 分流

评论(0) 引用(0) 浏览(11318)

ros统计内网在线人数

post by rocdk890 / 2012-11-12 11:57 Monday 网络技术

#内网地址段改为自己的
/ip firewall address-list add address=192.168.1.0/24 disabled=no list=lan
/ip firewall mangle add action=add-src-to-address-list address-list=Online address-list-timeout=1m chain=prerouting ...

阅读全文>>

标签: ros 统计 内网 在线 人数

评论(1) 引用(0) 浏览(5987)

git常用命令(补)

post by rocdk890 / 2012-11-12 9:47 Monday linux技术

导入远程仓库
$ git clone https://github.com/yangtianxiang/test1.git

提交本地代码(master)
git status                               ...

阅读全文>>

标签: linux 命令 git

评论(0) 引用(0) 浏览(2285)

git常用命令

post by rocdk890 / 2012-11-10 22:17 Saturday linux技术

创建git项目仓库

$git init

配置个人登记信息,这样团队协作的时候,就可以看到哪个用户修改过哪些文件的

$git config --global user.name 'cfanbo'
$git config --global user.email "baidu@gmail.com"

如果有些临时文件,没有必要提交到分支的话,可以将文件名或者路径信息写到一个 .gitignore ...

阅读全文>>

标签: linux 命令 介绍 git

评论(0) 引用(0) 浏览(1559)