友情提示:欢迎光临!出售wenca.cn和hkrun.cn域名,有要的请M我qq:316358892

centos7清理docker垃圾文件

post by rocdk890 / 2020-5-22 16:09 Friday linux技术

    相信很多朋友都有这个docker容器导致主机磁盘空间满了的问题,应用容器在宿主机上长期运行,应用实例启停容器,会产生大量的停止的容器,无容器使用的数据卷、网络配置,无容器依赖的镜像,这些垃圾日积月累,会影响到宿主机的运行状态,造成机子卡顿等现象。因此,需要对这些宿主机的垃圾进行清理.下面我们来看看怎么清理.
    系统:centos 7.x(64位)

1.查看docker磁盘使用情况
docker system df
TYPE        &n...

阅读全文>>

标签: centos 镜像 清理 空间 磁盘 docker 容器 垃圾文件

评论(0) 引用(0) 浏览(115)

shell脚本监控https证书到期时间

post by rocdk890 / 2020-4-13 15:55 Monday linux技术

    上周5(2020年4月10号)正在认真的上班,突然手机支付宝来了一条信息,原本以为又是什么广告,没想到居然是一条转账信息,如下
  点击查看原图
    本来想给这位朋友回句谢谢的,但找了半天都没有找到怎么回复,所以我只好加到这篇文章开头里,这是我写blog以来,除了广告和友链收到的第一笔赞助费,我在这里由衷的感谢这位朋友的支持.

cat /root/soft_shell/check_https.sh
#!/bin/bash
################ Version Info ##################
# Author: ...

阅读全文>>

标签: centos 时间 shell 监控 ssl 证书 https check 到期

评论(0) 引用(0) 浏览(233)

ROS VRRP单线多拨均衡配置脚本

post by rocdk890 / 2020-3-30 16:45 Monday 网络技术

本脚本适合MikroTik RouterOs v6.45.x,适合宽带单线接入用户配置,如果你是多线的,请自行修改.

# 单线三拨流量均衡配置
/interface vrrp
add name=vrrp1 arp=enabled authentication=none disabled=no interface=wan interval=1 mtu=1500 preemption-mode=yes priority=100 vrid=1
add name=vrrp2 arp=enabled authentication=none disabled=no interface=wan interval...

阅读全文>>

标签: 脚本 ros pcc vrrp 单线多拨 单线 多拨

评论(0) 引用(0) 浏览(346)

centos7 一键安装docker,docker-compose环境

post by rocdk890 / 2020-3-19 11:01 Thursday linux技术

  docker环境相信大家都有在用,但安装环境过程太烦人了,所以我写成一键安装脚本来解放双手.
  系统:centos7.x(64位)

cat /root/soft_shell/auto_install_docker.sh
#!/bin/env bash
export PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
clear

# 检查是否 root 用户
if [ $(id -u) != "0" ]; then
    echo "Error: You must be root to run this sc...

阅读全文>>

标签: centos 安装 shell install 一键 docker centos7 docker-compose

评论(0) 引用(0) 浏览(255)

centos7 shell脚本一键安装maven

post by rocdk890 / 2020-3-6 18:18 Friday linux技术

最近装什么都希望自己有个一键脚本来搞定,今天看到以前的maven还没有写一键安装脚本,所以今天把他补起.
系统:centos 7(64位)

cat /root/soft_shell/auto_install_maven.sh
#!/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
export PATH

# Check if user is root
if [ $(id -u) != "0" ]; then
    echo "Error: You must be root to run this script, ...

阅读全文>>

标签: centos 安装 shell install 一键 maven

评论(0) 引用(0) 浏览(276)

centos7 shell脚本一键安装nodejs

post by rocdk890 / 2020-3-4 14:30 Wednesday linux技术

好了,python的一键安装有了,当然nodejs也得有个一键安装,毕竟这两个东西是大家经常会用到,有需要的小伙伴可以拿去.
系统:centos 7.x(64位)

cat /root/soft_shell/auto_install_node.sh
#!/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
export PATH

# Check if user is root
if [ $(id -u) != "0" ]; then
    echo "Error: You must be root to run th...

阅读全文>>

标签: centos 安装 shell install 一键 nodejs

评论(0) 引用(0) 浏览(236)

centos7 shell脚本一键安装python3.7或3.8

post by rocdk890 / 2020-3-3 12:19 Tuesday linux技术

在上一篇文章centos7 shell脚本一键安装python3.7发布了之后,我同事看到了问我,你为什么不用python3.8,当时我就蒙了,对啊,还有人需要装3.8的版本的,今天对其进行了修改,让其支持安装python3.8,有需要的朋友可以看看.
系统:centos 7.x(64为)

cat /root/soft_shell/auto_install_python3.sh
#!/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
export PATH

# Check if user is root
if [ $(i...

阅读全文>>

标签: centos 安装 shell install 一键 python 自动

评论(0) 引用(0) 浏览(240)

centos7 shell脚本一键安装python3.7

post by rocdk890 / 2020-2-20 11:18 Thursday linux技术

最近要安装个东西,发现要python3才能支持,为了方便以后不用进行重复性工作,我就写了个一键安装python 3.7的脚本.
系统:centos 7.x(64位)

cat /root/soft_shell/auto_install_python3.sh
#!/bin/bash
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
export PATH

# Check if user is root
if [ $(id -u) != "0" ]; then
    echo "Error: You must be root to ru...

阅读全文>>

标签: centos 安装 shell install 一键 python 自动

评论(0) 引用(0) 浏览(258)

shell脚本自动修改centos7网口名称eth0并配置ip

post by rocdk890 / 2020-2-19 14:16 Wednesday linux技术

2020年真是个不好的开始,还没有开始过年就出现这么大的疾病,呆在家里呆了这么多天实在是太无聊了,就写了几个脚本.
系统:centos 7.x(64位)

cat /root/soft_shell/network.sh
#!/bin/env bash
PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
export PATH

# Check if user is root
if [ $(id -u) != "0" ]; then
    echo "Error: You must be root to run this sc...

阅读全文>>

标签: centos shell ip 一键 自动 静态 eth0

评论(0) 引用(0) 浏览(228)

使用docker maven进行编译

post by rocdk890 / 2019-11-15 11:28 Friday linux技术

之前我们在docker里运行jar包,最近因为maven编译环境和ant编译环境出现冲突,所以我打算把maven丢到docker里去进行编译,这样就不会影响到ant的编译环境.好了,废话不说多,我们来看怎么搞.
系统:centos 7.x(64位)
环境:docker 18.09.6

1.安装好docker环境
yum-config-manager \
    --add-repo \
    https://download.docker.com/linux/centos/docker-ce.repo

yum install docker-ce -y

system...

阅读全文>>

标签: centos 编译 maven docker

评论(0) 引用(0) 浏览(1033)

docker安装jdk11运行springboot的jar包

post by rocdk890 / 2019-10-28 10:19 Monday linux技术

公司最近使用springboot框架来构建导出服务,但编译成jar包来运行,为了方便部署和有个守护进程,所以我们采用docker来运行.
系统:centos 7.x(64位)
软件环境:docker 19.03.4

1.安装docker
怎么安装这里就不说了.

2.编写dockerfile文件
cat dockerfile
FROM openjdk:11.0.4
EXPOSE 8080
RUN mkdir /download
ENTRYPOINT ["java","-Duser.timezone=GMT+8","-Djava.security.egd=file:/dev/./urandom",...

阅读全文>>

标签: centos 安装 运行 jdk docker jdk11 spring

评论(0) 引用(0) 浏览(882)

centos7把/home空间合并到/(根目录)

post by rocdk890 / 2019-8-27 15:18 Tuesday linux技术

  大家在使用虚拟机创建centos系统的时候,会发现原本打算分配的空间,有一部分给/home分配走了,这样就造成我们的根目录空间不够,所以我们要把/home分配走的空间还给根目录.
   系统:centos7(64位)
1.先查看空间分配情况
df -h
Filesystem               Size  Used Avail Use% Mounted on
/dev/mapper/centos-root   38G  978M  &...

阅读全文>>

标签: centos 合并 空间 硬盘 分区 disk

评论(0) 引用(0) 浏览(612)

mysql 5.7搭建MGR多主模式

post by rocdk890 / 2019-7-31 17:18 Wednesday linux技术

  mysql有很多复制模式,今天给大家讲下mysql的组复制(MySQL Group Replication).
        系统:centos 7.x(64位)
软件版本:mysql 5.7.25
环境:
db1 10.0.2.246
db2 10.0.2.247
db3 10.0.2.248

1.安装mysql
这里不多说了,mysql都安装不来的,我觉得也不用看下面了.

2.配置db1(10.0.2.246)节点.
vim /etc/my.cnf
[client]
socket = /data/mysql/mys...

阅读全文>>

标签: 配置 mysql 搭建 MGR 多主

评论(0) 引用(0) 浏览(453)

debian 9安装nodejs和npm

post by rocdk890 / 2019-4-28 14:53 Sunday linux技术

在github上找了个socks5的代理,但他这个要npm才能安装,要nodejs才能使用,项目地址是https://github.com/Srar/telegram-socks5-proxy,下面来说说怎么在debian 9上安装nodejs和npm.
系统:debian 9

1.添加Node.js PPA
最新版安装命令:
apt-get install curl python-software-properties
curl -sL https://deb.nodesource.com/setup_10.x | sudo bash -

安装LTS长期维护版:
apt-get install curl python-so...

阅读全文>>

标签: 安装 install debian nodejs npm

评论(0) 引用(0) 浏览(2087)

centos7使用lftp自动上传文件到ftp

post by rocdk890 / 2019-4-10 14:03 Wednesday linux技术

今天公司AI部门要求把每天的mysql数据传到他们ftp服务器上,我用ftp客户端试了发现居然是主动模式的,可能我写的ftp自动传输的shell脚本有问题,居然每次都超时连接,只好使用lftp来进行传输.
系统:centos 7
软件:lftp
脚本如下:
cat /root/soft_shell/lftp_upload.sh
#!/bin/bash
today=$(date +%Y%m%d_%H%M%S)
file=$today.sql.gz
user=rocdk890
passwd=rocdk890
ldir=/data/sqlbak/
rdir=/
ip=47.92.x.x

l...

阅读全文>>

标签: centos mysql ftp shell 脚本 数据 传输 lftp

评论(0) 引用(0) 浏览(882)