centos7 yum安装vim 8

post by rocdk890 / 2017-7-24 17:31 Monday linux技术
  最近centos系统上出现了vim输入验证漏洞,vim patch 8.0.0056之前的版本中存在安全漏洞,该漏洞源于程序没有正确验证‘filetype’、‘syntax’和‘keymap’选项的值,攻击者可利用该漏洞执行任意代码.
  系统:centos 7.x(64位)

1.先卸载老的vim
yum remove vim-* -y

2.下载第三方yum源
wget -P /etc/yum.repos.d/  https://copr.fedorainfracloud.org/coprs/mcepl/vim8/repo/epel-7/mcepl-vim8-epel-7.repo

3.安装vim
yum -y install vim-enhanced sudo

4.验证vim版本
rpm -qa |grep vim
vim-enhanced-8.0.0704-1.1.26.el7.centos.x86_64
vim-common-8.0.0704-1.1.26.el7.centos.x86_64
vim-minimal-8.0.0704-1.1.26.el7.centos.x86_64
vim-filesystem-8.0.0704-1.1.26.el7.centos.x86_64

可以看到vim已经是8.0的版本了.
夜空- 本站版权
1、本站所有主题由该文章作者发表,该文章作者与夜空享有文章相关版权
2、其他单位或个人使用、转载或引用本文时必须同时征得该文章作者和夜空的同意
3、本帖部分内容转载自其它媒体,但并不代表本站赞同其观点和对其真实性负责
4、如本帖侵犯到任何版权问题,请立即告知本站,本站将及时予与删除并致以最深的歉意
5、原文链接:blog.slogra.com/post-705.html

标签: centos yum 安装 update install centos7 vim

  1. 2017-07-31 17:58
    @snake_boy:centos6.x的目前只能编译安装,yum的还没有
  1. gravatar snake_boy
    2017-07-27 13:40
    Centos6.x  平台的呢

评论: